Knowledgebase: DotNetNuke
CS1703: An assembly with the same identity ‘System.Web.Extensions, Version=4.0.0.0
Posted by Sean Syed on 04 June 2013 09:41 PM

You tried to change the ASP .Net version from 2 / 3.5 to ASP .Net Version 4 / 4.5 and receive the following error:

Compilation Error

Description: An error occurred during the compilation of a resource required to service this request. Please review the following specific error details and modify your source code appropriately. 
Compiler Error Message: CS1703: An assembly with the same identity ‘System.Web.Extensions, Version=4.0.0.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35′ has already been imported. Try removing one of the duplicate references. 
Source Error:

[No relevant source lines]

SOLUTION:

Have a look under DotNetNuke website_root/bin folder a DLL file called " System.Web.Extensions.dll" rename this file to any other file i.e. " System.Web.Extensions.dll.old".

(21 vote(s))
Helpful
Not helpful

Comments (0)
Post a new comment
 
 
Full Name:
Email:
Comments:
CAPTCHA Verification 
 
Please enter the text you see in the image into the textbox below (we use this to prevent automated submissions).