Knowledgebase
Domain DNS not resolving in Plesk
Posted by Sean Syed on 23 February 2013 05:03 PM
"There is a bug with the Windows Parallels Plesk Control Panel that can sometimes cause a domain to get added to the BIND service twice.  This would prevent the domain from being accessible and would show no DNS records even though the Blacknight Control Panel shows the domain as being added to Plesk successfully and though all the DNS settings in the Plesk Control Panel are correct."

 

Open a command prompt and go to the Plesk admin bin directory. Most likely: C:\Parallels\Plesk\admin\bin or C:\SWSoft\Plesk\admin\bin. E.g:
cd C:\Parallels\Plesk\admin\bin

 
Run the following command:
dbclient.exe --direct-sql "--sql=select id,name,status from dns_zone"


This will show you a list of all the domains in the BIND service on your server (i.e. domains added to the VPS). Any entry with a 2 beside it usually means an error. In this case there would be two entries for your_domain_name.com, one with a 2 beside it, as it was an incorrect duplicate entry.


What you need to do then is note down the ID number to the left of the entry for the duplicated domain name (the one with the 2 instead of 0 at the end) and then run the following commands:

dbclient.exe --direct-sql "--sql=delete from dns_recs where dns_zone_id=XX"
dbclient.exe --direct-sql "--sql=delete from dns_zone where id=XX"
where XX is the ID number. In this case it is 10.


Then finally run one last command to update BIND on the server:

DNSMng.exe update *

(1 vote(s))
Helpful
Not helpful

Comments (0)
Post a new comment
 
 
Full Name:
Email:
Comments:
CAPTCHA Verification 
 
Please enter the text you see in the image into the textbox below (we use this to prevent automated submissions).