Knowledgebase
How to upgrade PHP version for Parallels Plesk?
Posted by Sean Syed on 21 February 2013 07:24 PM

In order to upgrade PHP to the needed version (if you would like to have other than shipped with Parallels Plesk) please perform the following steps:

  1. Stop Plesk services (‘Control Panel’ and all that are included in the ‘Plesk Run-Time’ section)
  2. Rename folder %plesk_dir%\Additional\PleskPHP5 to the orig_PleskPHP5
  3. Create a new folder %plesk_dir%\Additional\PleskPHP5
  4. Download needed version of PHP, unzip its content, and copy it to the newly created folder PleskPHP5
  5. Copy the file php.ini from old folder orig_PleskPHP5 to the new one
  6. Make sure the permissions are inherited
  7. Start Plesk services
  8. Click "Refresh" button in Components Management section in Parallels Plesk Panel and check if you can see the new PHP version there

You need to be aware that PHP versions other than shipped with Parallels Plesk Panel were not tested.

(2 vote(s))
Helpful
Not helpful

Comments (0)
Post a new comment
 
 
Full Name:
Email:
Comments:
CAPTCHA Verification 
 
Please enter the text you see in the image into the textbox below (we use this to prevent automated submissions).